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Disassembly

Introduction

Responsible care should be taken during the disassembly and reassembly of the
units in order to avoid damaging or stressing the housing and internal components.
Ensure that a properly grounded high impedance conductive wrist strap is used while
performing these procedures on electronic units.

Many of the integrated circuit devices used in this equipment are
vulnerable to damage from static charges. Ensure that adequate static
protection is in place when handling, shipping, and servicing the internal
components of this equipment.

Recommended Tools

The following tools (or similar tools with the same functions) are recommended for
use during the disassembly and reassembly of the phone.

Anti-Static Mat (Ground Cord included)

Anti-Static Wrist Strap

« Torque Screw Driver (T5 type, torque is set to 1.2kg-cm)
« Tweezers
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Disassembly Procedure

The following information describes the procedure for removing and accessing
various parts of the phone.

Case 4 Removal
1. Turn off the telephone.
2. Slide down the battery cover.

3. Remove the battery pack
from Case 4.

4. Remove the SEAL label.
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5. Release the four screws and
remove them.

6. Unclip the 2 snap fits from the left
and right hand sides of the unit and
separate Case 4 from Case 3.

7. Remove speaker from Case 4
by tweezers.
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7. Unlock FPC board to board connector
from Main board carefully.

Main Board Removal
1. Carefully separate the main
board from the Case 4.

2. Remove SIM Card Mylar
from shielding case.
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3.Remove the Shielding case (RF)
by tweezers.

4.Remove Shielding case (BB)
by tweezers.

5.Place the main board facing

downwards on an anti-static mat.
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6.Remove right and left side-key.

7.Remove keypad from Case 3.

LCD Module Removal

1.Remove screw label by tweezers.
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2.Remove Logo by tweezers.

3.Release the three screws and
remove them.

4.Remove LCD Lens.
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5.Remove Capacity Rubber
by tweezers.

6.Unlock LCD Module connector
by screw driver carefully.

7. Carefully separate LCD Module
from Case 1 by bending the
locking Tab.
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8.Place a protection tape over
the LCD Module.

NOTE | Do not touch the LCD

module with your hands!

9.Separate Case 1 and Case 3 by
pressing hinge and remove Case 1
Carefully.
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10.Reomve FPC from Case 1
carefully.

Assembly Procedure

Once the unit is disassembled and the repair is carried out, it then becomes
obvious that to assemble the unit, the procedure is the reverse of that previously
completed for disassembly.
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14. CSTN Logo
42.G4803.001

13. Assembly, Case2

60.G4801.001
12. LCD Module
54.G4802.001
22. Flipper screw label o L
40.G4801.001
rf. I% 2 :1;-‘
8. Assembly, Casel & 3 & .
60.G4811.001 = @&,
= 9. Keypad, P+Film
47.G4807.001
5. Metal Dome

1. Assembly, PCB 34.G4801.001

99.G4821.001 X

4. Assy, Sidekey FPC, Right
«— | 60.G4805.001
6. Microphone _ i
23.42007.051 =
7. MIC Cap 11. Side key, right
47.G4809.001 / 47.G4805.001
2 -

16. Assy, Case4 :

60.G4806.001 21. RF switch cap

. 47.G4810.001

20. Battery Door

19. Battery, V290/V295
39.G4805.001

60.G4809.001
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19. Battery
60.G4809.001

2. SIM Mylar
40.G4804.001

10. Side-key, Left
40.G4804.001

3. Side key FPC
60.4804.001

20. Battery door
39.G4805.001

24. Nameplate Motorola
40.G4810.001

23. Product Label

18. Screw
86.00T11.3R5

17. Antenna
25.90036.011

16. Assy, Case4
60.G4806.001

15. Polyphonic Speaker
23.4G480.001
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4. Audio Jack
22.13021.011

7. Antenna connector
21.M0001.001

9. RF shielding Case
60.G4801.001

2. SIM connector
22.1D008.001

8. BB shielding Case
60.G4802.001

6. BTB connector
20.0.1048.034

o

1. Battery Connector

21.N0025.001

5. MIC holder
21.N0033.001

3. DC jack

22.10280.011
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Spare part list

NO |P/N DESCRIPTION QTY
1/20.0.1048.034 BTB CONNECTOR 1
2|21.M0001.002 CONN ANTENNA ACT/216-800 56F05 1
3|21.N0025.021 CONN SMD BATT 3P BLACK 56F05 1
4|21.N0033.001 CONN MIC 10D KK25302-GC 56D91 1
5|22.10280.011 SKT JACK PWR 4P ACON/PJK15 1
6/22.13021.031 SKT JACK AUDIO RT5P ACON/AJRAT 1
7|22.1D008.011 SKT SMD SIM 2R6P H1.9 ACT/217 1
8/23.42007.051 MICROPHONEZ2.2K58DB WM-64MNY102 1
9/23.4G480.004 SPEAKER 1W7.40H MSP1218A-01 V4 1

10|25.90036.011 ANTENNA D/B ANADIZD BLUE 56F05 1
1134.G4801.006 VITA METAL DOME 56F05 1
12|39.G4805.002 COVER BATTERY VITA 56F05 1
13/40.G4801.001 LABEL SCREW V290 2
14/40.G4810.011 NAME PLATEMOTOROLA SILVER TEAL 2
15|40.G4804.002 MYLAR SIM-BLACK 56F05 1
16/40.G4810.001 NAME PLATE MOTOROLA BLUE 56F05 1
17|47.G4804.005 VITA SIDEKEY LEFT 56F05 1
18|47.G4805.005 VITA SIDEKEY RIGHT 56F05 1
19|47.G4807.006 KEYPAD V290 P+F ENG. 56F05 1
20/47.G4809.001 MIC CAP 56F05 1
21/47.G4810.006 RF SWITCH CAP 1
22/56.07G48.009 LCD MODULE LP8670-B PHILIPS 1
23/60.G4801.001 RF SHIELDING CASE 1
24160.G4802.001 ASSY BB SHIELDING CASE 1
25|60.G4804.005 ASSY FPC SIDEKEY LEFT 56F05 1
26|60.G4805.005 ASSY FPC SIDEKEY RIGHT 56F05 1
27|60.G4806.003 ASSY CASE4 VITA 56F05 1
28|60.G4808.002 ASSY BATT VITA LIION 700MA W/O 1
29/60.G4810.005 ASSY CASE2 METAL BROWN 1
30/60.G4811.004 ASSY CASE1+CASE3 BLUE 1
31/60.G4820.001 ASSY CSTN LOGO 56F05 1
32/86.00T11.3R5 SCRW FLAT TORX M1.6*3.5L NI 8
33]99.G4821.002 ASSY PCB 1
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Download
Introduction
This document describes all functions in service

XDMTool.

© System requirement and setup:

Minimum requirement:
Operation system: Win95/ Win98 / WinNT / Win2000.

CPU: Pentium 233 MHZ or higher.
Hard Disk: Free 10MB space.

Memory: 64MB RAM.

Input Device: Keyboard and mouse

Calibration requirement:
1.Instrument for calibration Hp8922M GSM/DCS/PCS MS Test Set
Hp8960 GSM/DCS/PCS RF Interface
2.GPIB interface card and cable For RF calibration

3.Power Supplies:
HpE3631, Hp66332A , Hp66311 , Hp66111 , HP66309

4 .Communication cables Rs232 and Acer Downloader
5.RF Cable 50 ohm cable for RF calibration.
6.Dummy battery For RF and battery calibration.

Setup in window:

In Windows 95/98/NT/2000, extract the XDMTool compress files to any
temporary directory. It will create DISK1and DISK2 this subdirectory. Please go
into the DISK1 and double click the setup.exe. The Install shield will auto setup the
XDMtool in your operating
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© Function Description:
A. New Download:
B Download interface and download code type

The download interfaces : RS232 — Normal, RS232 — Middle,
RS232 — Fast . The download code type consists of boot code,
program code and language pack. Up to now, the language pack
IS not supported

B Baud rate and data cable

When you select RS232—Normal to download, the baud
rate is 115200, it uses the normal Rs232 data cable. But when
you choose RS232 — Middle or RS232 — Fast to download, you
must have a

“USBToRs232” data cable, or it will not work.

In general, the user uses the common RS232 data cable to
start the download procedure. However, USB-t0-RS232 data
cable should be used to the fast download procedure with
403200 baud rate.

m Com port

New download support multi-download functionality, you

7
must press the button il to open the com port that you want

to download, After opening, it will be changed : L

B Boot code and Program code:

After choosing the interface and com port, you must select the
boot code and program code.

Boot code: r BRom_BrVL _001.mot

Tool version: >=1.4.1

BENQ ’
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- Download interface: RS232 interface
- Current load version in handset: >=0.39
- New download load version : any version
Solution:
- Boot code: new boot code (r_BRom_BrVL_004.mot).

Program code:

The extension name of program code is “mot”, you can choose
it by pressing “File>LoadMot” to select the correct program code.

Finally, before starting press “Download” button on tool bar, you must
power off the handset first. When the string “Wait for target ready”
appears, press the end key, then the download process starts.

Remark:

It must be emphasized that never stop or remove the power
supply (battery) when your handset is downloading the block 0 and
block 1 program codes. It is writing critical boot codes at this time. If
you terminate the download process at this moment, this handset not
only can not power on but also can not be re-download again. In this
case, the only solution is using a special “JTAG interface and cable
“to do a low-level download.

2.2 General View

1. Click “View”->"New Download” menu item and the main view would be
showed such as Fig.2.1.
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= Fir Cram Ve G0 Wodw B —=1— Menu Bar
3300 wm@ry < Tool Bar
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Fig.2.1. The user-defined file system manager view.

3 Multi-Fast-Download
Functions

We separate the functions of the multi-fast-download into three parts include
download code assignation, download procedure and independent command
operation.

First, before starting download procedure, the user should specify the essential
code file paths and then the program would convert it to binary blocks in memory.
Second, these block blocks would be downloaded to the handset through the
communication data cable when starting download procedure. Final, after finishing
the download procedure, the user could then control the handset via the commands.

3.1 Download code assignation

1. Click “File”->"Load Mot” or “File”->"BootCode” menu items or tool bar
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icons to specify the download code file paths. The operation is shown as
Fig.3.1.

g EDMToolR - [New Download] 2 EDMToolR - [New Download]

Tl Eie Option Wiew Go Window =i Fle Opfion View Go Wink
‘ ] W PRI ¥ ol 7 [
Load ot el h ﬁa % | @ @ | EEJL @’r I

BoatZode

= alContiE el o | .

(a)
= EDMToolR - [New Download] 2 XDMToolR - [New Download]

=l Ble Option View Go Window T Fle Option View Go Wind

Loedm CrleM _ﬁ' y§| ol | T @%

Fig.3.1. Assign (a) program code or (b) boot code.
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2. The specified file path and its converted binary block size would be showed
as Fig.3.2.

File path --

¥ Boot code: iogram Files"EenQ4xDMToolR 0.071 betahr rd.mot

W Program code: 1&51:, datayVita lite 0.04 with MMIZVL100410.mot

[T Languace pack: {{{ Non-specified »»

(a)

Dotmload task infomatiomn:

Conwverting boot code is success. Conwverted length: 4092 bytes. I
Converting program code is success. Conwerted length: SE8E25336 hytes.w

(b)

Fig.3.2. (a) Specified file path and (b) its converted binary block size.
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3.2 Download procedure
3.2.1 Download interface

1. Click the list box and specify a download interface. The operation is shown

as Fig.3.3.
Interface: I{{ Non-specified == -
f MNon-specifisd = :
[" Boot code: RS737  -- Mormal { 115200 ~ 115200 }
B3Z3Z -— Fast [ 403200 ~ 403200 3
[ Program code: 1{{ Non-zpecified =»

Fig.3.3. Specify a download interface.

3.2.2 Communication device

1. Click download status button to indicate whether its associated
communication device would be used in download procedure. The
operation is shown as Fig.3.4.

- Btatus

\/ COM 1: << Specified »=

&

COM Z: == Hon-specified ==

Fig.3.4. Indicate essential associated communication device.
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3.2.3 Start the download procedures

1. Fig.3.5 illustrates to start a download procedure. The specified
communication device would be running and download procedure

information would be showed.

C} COM 1: Tramsmitting partition 3 ..
n

g ¥DMToolR - [New D

Lovmload task infomation:

Status

[COM 1]:
[CoM 11:
[COM 1]:
[COM 1]:
[CoM 1]:
[CoM 1]:
[COM 1]:
[COM 1]:
[CoM 11:
[COM 1]:
[COM 1]:
[CoM 1]:
[COoM 1]:
[COM 1]:

Transmitting partition 3 ..., Percentagea:
Block dovmloading. .., Percentage: Ej
Block dovmloading..., Percentage: Z%
Block dowmloading. .., Percentage: F%
Block dovmloading. .., Percentage: I%
Block dovmloading. .., Percentage: %
Block dowmloading. .., Percentage: Z%
Transmitting partition & ..., Percentags:
Block dovmloading. .., Percentage: 1%
Block dovmloading..., Percentage: 1%
EBlock dowmloading..., Percentage: 1%
Block dovmloading. .., Percentage: 1%
Block dovmloading. .., Percentage: 1%
Block dovmloading..., Percentage: 1%

(b)

=

Fig.3.5. (a) Start a download procedure and (b) its download infomation.
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3.2.4 Stop the download procedures

1. The use could stop all current procedures or the independent one. The
operation is shown such as Fig.3.6.

O EDMToolR - [Hew D

COM 1: Wait For Target Beadsy. .
: dl

(b)

Fig.3.6. Stop (a) all procedures or (b) independent one procedure.
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B. Power off set default:

Fig.1 illustrates to start a command procedure. The specified
communication device would be running and command procedure
information would be showed.

-+ Commend Configuration

Commard : I{{ Powar-off Setc Default == vl

<< Mon-specified ==

Dovmload task infomation:

[COM 1l]: Power-off set default command success., Percentage: 100%
[COM 1]: Wait For Target Ready.., Percentcage: 0%

(b)
Fig.1. (a) Specify and (b) its command
information.
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C. Auto Calibration

(1) Calibration connects cable:

GPIBR PC Com
! L
GPIE Rs232
GPIB
[ 1] L1 -
1 . Acer
Calibration Power
) downloader
Instrument  Rr output Supply vy o el
GSM D 7] Fower
L1 1)
(1
RF Cablz |_
Power lines
sty € | Dummy battery

Downloader cable

PS:

1. In some calibration instrument, the RF output of GSM and
DCS are different, so you must calibrate GSM and DCS each
other.
2. If you have no connector with power supply and Acer
downloader, you can get a travel charger and cut it, then
divide the positive and negative electrode to connect into
power supply.

(2) Calibration Item:

2-1.Configuration file :

The auto-calibration configure file contents some optimal value for

some object in handset and some parameters dependent on
] i
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2-2.Calibration Type :
The calibration type was divided into two parts: Auto
Calibration and Manual Calibration.
2-3.Auto Calibration :
Choose the items that you want to calibrate when running
auto-calibration

function.
AFC: Frequency.
AGC: RxGain.
APC: TxPower.
ADC: Battery is for battery A/D converter calibration.
ARC: Ramping table calibration.

(3) Before running Calibration:

Before start calibration you must check the following things:
3-1 Change your battery to dummy battery.
3-2 Check connect cable is OK?
3-3 Check GPIB interface is OK?
3-4 Power on power supply and set it to 3.8V

(4).Run Calibration:

4-1.Click “View”->"Auto Calibration” menu item and the main
view would be showed such as Fig.2.
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4] File Option ¥iew Go Window Help

BA B Y

— Input Information

Config | Config file

A

Calibration iUn.knom'n Device

<\\ Calibration

Calibration Item

Device
¥ Auto Calibration

" Manmal-Calibration

GsM / — - Tx Commarn Cal Item 'i
/ feDuratieon (sec) =

i Power Lw = 0

Arfeocn = 0
PC3 vI
>

L APC Walue = 0

MISC. v|

Before calibration, make sure wou hawe setup all the settings:

l. Choose a config £ile.

2. Select a calibration type | Auto Manual)

3. For Auto Calibrate:

[1l).Click the Gsm band, DIcs band, Pcs band and Misc buttons l{:/Fessagewindow
O0choose calibrate items

4. For Manual Calibrate:

f (RIS ; ]
[2).As=sign new walue to relative fields
5. When all settings are done. click the [run] button i

Select which item Woll want to

do ex

Eeriments

Fig.2. The Auto Calibration main view.
Terminology:

Message Window: Display all related information during
calibration.

Calibration Item: To select calibration items.

Calibration Device: Shows the calibration device is used during
the calibration process.

DataBase File: The corresponding database file of the handset
software load

4-2.Performing a Calibration

This Section is to demonstrate how a user can operate a calibration
process step-by-step.

(1). Setting up Com Port and Baud Rate
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1. Click “Option”->"Device” menu item to assign serial
communication port and “Option”->"Baud Rate” menu item to
specify the baud rate. Fig.3 shows these operations.

B |_Qp1iun View Go Window Help @tﬁ Wiew Go Window Help
* Device > |v 0 9 5

2 Baud Rate » COMZ i Baud Rate P

“TTIE

i |

(1) (2)

Fig.3 Specify the (1) serial communication port and (2) baud rate.

(2). Assign a corresponding database file

1. Click “File”->"Database” menu item to assign a database file. User

can also click on the Database button to perform the same task.

Fig.3.1 shows these operations.
=1 ool - [Calibraton
4 File Option Yiew Go Window Help

E Load kot EEI T %, @

Enotizade S rE

CalConfiz Chl+L

BEp EEE
a0l 0121%est2 cfix

Eecent FPF File
Eecent Database File

r r

Exit

[ (1)

B Tool - [Calibratiogn]

24 File Option ¥iew Go Window Help

3300w BQ

|—Input Inforrnation (2)

Fig.3.1. Select a database file (1) from menu (2) from button.
(3). Selecting the desired calibration items

1. Select the desired calibration item as figure 4.
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— & uto Cabhration
G5 - |

[w] AFC -- Frequency Exor [%l

[w] LGC -- Rx Calibration
[w] LPC -- T Calibration

WISC. -

Fig.4 Select the desire item for calibration

(4). Assign a Configuration file

1. Due to different model of handset, the setting of the configuration
file may be different. To select a configuration file, click

“File”->"CalConfig” menu item from menu bar, or simply click on
the configuration file button.

é Lcad! Bt ] H T
Eootizode
CalConfix
Databasze

ESy Bp ZltE =

Recent PPF File 13| eemme|
rice

Eecent Databass File L

Ezit

(1)

ile thu:un View Go  Window Help

IR 2]

| @

Fig.5. Select the configuration file from (1) menu bar (2) configuration file button.
(5). Run

There are 2 kinds of calibration. Auto Calibration and Manual
Calibration.

5-1.Auto Calibration
To run an Auto calibration, proceed to the following steps.

1. First go through steps that was described in the first.

2. Click on the radio button “Auto Calibration” as figure 6.1.

BENQ "
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3. Click on the run button as figure 6.2.

—i{% huto L\xlialihratin:-n —

‘ =50 - I ‘

Fig.6.1 To select auto calibration radio button
Tonl - [Calibration)

= Fil: Option ¥View Go Window Help

2|0 -8

‘ |—Input Inforrnation

Fig.6.2 To execute a auto calibration

5-2.Manual Calibration
To run a Manual Calibration, proceed to the following steps.

2. First go through steps from was described in the first.

3. Click on the radio button “Manual Calibration” as figure 6.3.

~ % Manusl-Calibration —

e Cal Tte

Fig.6.3 To select Manual calibration radio button

4. Select TX command or RX command on desire band by clicking
on the Cal_Item button as figure6.4.

Cal Itenm v|

W T Cormrmand
DC F v BExCommand
PCE g

Fig.6.4 To select desired command
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3.1 .Fill in the input parameters
TX command parameters:
Duration: the duration in seconds for running a TX command.
Power Lv: Power level to be tested.
Arfcn: Arfen to be tested.

APC Value: APC Value to be tested. Refer to Appendix A.4 for the
recommend APC value on each power level.

= T Commard

Fig.6.5 Input-parameter for TX command.

RX command parameters:

Duration: the duration in seconds for running a RX command.

Arfcn: Arfcn to be tested.

Gain: Gain value to be tested.

E----Duration [gec) = 0 =
E----Arfcn =0 [%

Fig.6.6 Input-parameter for TX command.

4. After input the appropriate parameters, simply click on the run
button.
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B Tool - [Calibration]
= Fil: Option ¥View Go Window Help

23RO~ eTS

|—Input Inforrnation

Fig.6.7 To execute a manual calibration
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