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 Introduction 

This document outlines the tools and processes a developer can use to create and test 
XHTML Basic, CHTML, and CSS content intended for deployment to mobile devices. The 
Motorola Browser Application Development Kit (ADK) is an Integrated Development 
Environment (IDE) built to develop and test wireless Internet applications. 

The main features of the Browser Application Development Kit include 

• Create web content using these markup languages: 

• CHTML 

• XHTML Basic 

• CSS 

• Test output on the Phone Emulator 

• Browsing functionality 

This document assumes that the developer is familiar with the basic principles of wireless 
applications and the use of XHTML, CHTML, and CSS. 

Document History 
 

Version Date Author Comments 
Draft (2.1) Oct 4, 2002 MW MDP Initial Draft 

Draft (2.1) Oct 18, 2002 MW MDP Second Draft 

Draft (2.1) Dec 11, 2002 MW MDP Third Draft 

Draft (2.1) Feb 17, 2003 MW MDP Fourth Draft 

Draft (2.1) Feb 25, 2003 MW MDP Fifth Draft 

Draft (2.1) Apr 16, 2003 MW MDP Sixth Draft 

Release (2.1)  MW MDP Final release 
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Features in this Release 
The following new features are included with this release: 

• Motorola A830 handset support 

• Ability to upload images to default or specific folders of the phone file system for use 
by the ADK 

• Ability to explicitly re-open the emulator  

• Use Cross Wire to pinpoint the location and color of any pixel on the display 

• Ability to set connection parameters and proxy information 

System Requirements 
The following describes the hardware and software requirements of the Browser ADK 
tools. 

Hardware Requirements 

• Windows PC with a 266 MHz Intel® Pentium® II or equivalent 

• 64 MB of RAM recommended 

• 80 MB of hard disk space 

Software Requirements 

• Windows NT® 4.0/Windows 2000/Windows XP 

• Microsoft® Internet Explorer 4.0 or higher 

• Microsoft® Data Access Objects (DAO) 3.5 

• Microsoft® Data Access Components 2.7 

• Java™ Runtime Environment (JRE), Standard Edition, 1.3.1 or later 

• Adobe Acrobat® 4.0 or later to read the documentation. The free reader application 
can be downloaded from http://www.adobe.com/products/ 
acrobat/readermain.html. 

• Small Fonts must be selected in the Display Control panel. 

NOTE: If the Microsoft Data Access Components or JRE is absent on your computer, the 
Browser ADK installation package installs them automatically. 
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Glossary 
Here are definitions of common terms used in this manual: 

Term Definition 

ADK Application Development Kit 

ASCII American Standard Code for Information Interchange  

CHTML Compact Hypertext Markup Language 

CSS Cascading Style Sheets 

DDE Dynamic Data Exchange 

IDE Integrated Development Environment 

ODBC Open Data Base Connectivity 

UI User interface 

WAP Wireless Application Protocol 

WML Wireless Markup Language 

WMLS Wireless Markup Language Script 

XHTML Extensible Hypertext Markup Language 

References 
The following references provide additional information on the technologies and materials 
discussed in this manual: 

Organization URL 

Motorola Developer Program www.motorola.com/developers/wireless 

O’Reilly & Associates www.oreilly.com 

Open Mobile Alliance, Ltd www.openmobilealliance.org 

World Wide Web Consortium www.w3.org 

 

The following specifications and books provide information on XHTML, WAP, and CSS: 

• HTML and XHTML: The Definitive Guide, 5th Ed., Musciano and Kennedy, O’Reilly 
and Associates, Inc. 

• Cascading Style Sheets: The Definitive Guide, Eric Meyer, O’Reilly and Associates, 
Inc. 

• WAP-277-XHTMLMP-20011029-a, Open Mobile Alliance, Ltd. 
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Browser ADK Overview 

The Motorola Browser ADK enables you to develop and test web content on a PC. The 
main functionality in the Browser ADK includes: 

• Writing XHTML, CHTML, and CSS content files using the Browser IDE 

• Test content using a Phone Emulator 

This chapter introduces you to the Motorola Browser ADK and describes its components 
and operation. 

Browser ADK Components 
The Motorola Browser ADK consists of two executable files:  

• Phone Emulator— The Phone Emulator is a separate executable that emulates the 
behavior of Motorola handsets and works in conjunction with the Browser IDE. It 
provides the interface in the form of a skin, which displays a specific model of the 
Motorola handset. 

• Browser IDE—The Browser IDE serves as a service to the Phone Emulator on which 
XHTML, CHTML, and CSS files can be tested for various phone types. The browser 
implemented in the IDE is the actual core browser code present in the mobile device. 
The Browser IDE us installed in the directory C:\Program 
Files\Motorola\Browser ADK 2.1. 

The IDE manages and orchestrates the operation of many internal code modules. These 
code modules implement the development tools used to write, edit, and browse content. 
The code modules consist of the following: 

• Editor—Use the editor module to write source code for XHTML, CHTML, and CSS 
source files. It recognizes any of the keywords in these page layout languages and 
displays them in a different color to assist code development. In addition, the editor 
also supports basic CSS editing with syntax coloring and file operations. The editor 
saves all source files as ASCII text. 

NOTE: The editor only recognizes language keywords; it doesn’t perform syntax 
checks.  

• Browser— Use the browser module to test the compliance of the XHTML, CHTML, 
and CSS files. This ensures that files created with the Editor module display properly 
on any target hardware using the same browser module. 
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Launching Browser ADK 

The file wapadk.exe in the Browser ADK 2.1 directory is the program that runs 
the integrated development tools. You can either make a shortcut to this file, or use the 
menu selection in the Start menu. Specifically, this is  

To launch the Browser ADK: 

• Choose the Start > Programs > Motorola Browser ADK > Browser ADK v2.1 > 
Browser ADK v2.1 menu item 

Important: The Browser ADK requires the use of the Java™ Runtime Environment (JRE) 
to operate. If you don’t have a JRE on your system, the installer will prompt you to install 
JRE 1.3.1_01. 

ADK Operation 
All of the software development tools are part of the IDE. You launch the Browser ADK 
IDE application, then write and test wireless programs from within the IDE. 

The IDE uses an Open Data Base Connectivity (ODBC) database to store configuration 
information. 

The Phone Emulator simulates the UI for the program under development. For this 
release, only the Motorola A830 is supported. This can be used to test and correct 
problems with the program’s user interface. 

The Phone Emulator is a separate executable file that is launched automatically when you 
start the IDE. Both the IDE and Phone Emulator use Windows Dynamic Data Exchange 
(DDE) interprocess communications to relay information to each other. 

Finally, the IDE is capable of connecting to a server via IP so that you can test the 
operation of wireless client software against server applications. 
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IDE Overview 

This chapter provides an overview of the Motorola Browser IDE. 

IDE Menus 
When you launch the Browser ADK IDE, the IDE’s main window appears, along with that 
of the Phone Emulator, as shown in Figure 1. 

  

Figure 1. The Browser ADK in operation, showing the IDE and the Phone Emulator 

The Browser IDE’s window is on the left, and the Phone Emulator’s window is on the right. 
You will spend most of your time during the initial stages of code development in the 
Browser IDE’s window. Once the program’s UI takes shape, and then you will make more 
use of the Phone Emulator. The Phone Emulator in the figure simulates the Motorola 
A830 handset. Other handset simulations are available. You can change the choice of 
handset display from a menu selection. 
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Browser IDE Menus 
The Browser IDE provides a number of point-and-click menus that assist in program 
development. These are: 

• File menu. This menu handles all file operations, such as opening or creating new 
source files, saving changes to a source file, and printing. The Recent Files… and 
Recent Projects… menu choices let you quickly open recently accessed source files 
or project files. 

• Edit menu. This menu supports source-editing operations such as Cut, Copy, Paste 
and Delete, as well as setting and using bookmarks. It also has commands that 
conduct search and replace operations in a source file. 

• View  menu. This menu handles the display of specific windows such as the toolbars 
and Project window. 

• Tools menu. This menu lets you configure and operate the IDE’s tools. It is where 
you select the handset skin used by the Phone Emulator (Tools > Phone Settings), 
enter communications settings that allow the browser to interact with a remote server 
(Tools > Connection Settings), and upload images (Tools > Upload Images). Other 
menu choices start the encoder or compiler, set or clear breakpoints, and have the 
WAP browser execute a program under debugger control. 

NOTE: The menu items Enable Debugger, Set Breakpoint, and Breakpoints are not 
supported in Browser ADK 2.1. 

• Window menu. This menu controls how the IDE presents specific windows, and to 
select or close active windows. 

• Help menu. This menu is where you access the Browser ADK’s help system. 
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Browser IDE Windows 
Within the scope of the Browser ADK window, several different types of windows can 
appear. These different types of components and windows include: 

• Toolbar–one-click access to most Browser IDE commands. See the section Browser 
IDE Toolbars for details. 

• Editor– provides the basic framework to write and edit content files. Multiple editor 
windows are possible, one per open editable file. 

• Output– displays information regarding the results of an encode/compile operation, 
and where code errors are reported. Two tabs enable you to switch between: 

• Output Wnd–select the Output window view to display the result of a WML and 
WMLScript compilation, whether successful or not.  

NOTE: Compilation is not supported in Browser ADK 2.1. 

• HTTP Headers–select to view the list of URLs accessed through HTTP mode. 
Includes header information like request sent, response received, method used to 
fetch content, type of content received, file size, and HTTP status (Figure 2). 

 

Figure 2. Examing an HTTP session using HTTP Headers. 
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At the very bottom of the IDE window is a status bar. It indicates what action the IDE is 
performing, where the editor’s insertion point is poised in a source file, and other status 
information. 

Browser IDE Toolbars 

The IDE Window toolbars provide one-click access to many of the program-specific 
commands. Each toolbar can be individually viewed or hidden using the View menu. The 
commands specific to each toolbar include: 

Toolbar Icons Actions 

 
Project commands–new, open, save, 
close 

 

Project File commands–add file(s) to 
project, build, remove file from project, 
open selected project file 

 
File commands–new text file, open file, 
save, save all modified files 

Standard Toolbar 

 Program commands–print, about, help 

 Editing commands–cut, copy, paste 

 Undo commands–undo, redo 

 
Find commands–find, repeat, find 
previous, find & replace 

Edit Bar 

 
Source commands–go to line, tab stops, 
set font 

Build Bar  
Compile and Debug commands–compile, 
simulate, set breakpoint 

Navigation Bar  
Navigation commands–back, forward, 
stop, upload images, home 

Bookmark Bar  
Bookmark commands–toggle, next, 
previous, and clear all 

Go Bar  
Provides a text box to enter URL’s and 
load web pages. 

Status Bar  

Displays the status of the Browser ADK 
application or the current action. Appears 
at the bottom of the window. 

 

To view or hide a toolbar: 

• Choose the View > Toolbar_Name menu item 
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• The selected toolbar is displayed and a checkmark appears before its name on the 
View menu if it was hidden, or hidden and the checkmark removed if already visible. 

Mouse Shortcuts 

The Browser IDE supports the following functions when right-clicking:  

• Within a window–displays a popup menu with options relevant to that window. (Only 
the window level commands are shown).  

• Item–displays a popup menu relevant to that item. 

• Between windowpanes or on a toolbar–displays a popup menu with options for 
quicker access to the commonly used commands (Figure 3). 

 

Figure 3. The list pop-up options that appear when you right-click inside the main Browser 
ADK window. 
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Setting the Phone Emulator 
The Browser IDE can support multiple Motorola devices. If more than one phone emulator 
is available, you can select it in the Phone Settings window (Figure 4). 

 

Figure 4. Use the Phone Settings window to select the emulator the Browser IDE uses. 

To select a different phone emulator: 

1. Choose the Tools > Phone Settings… menu item 

The Phone Settings window appears (Figure 4). 

2. Select a phone in the Select Phone Type list 

3. Click OK 

The next time you run the Phone Emulator, the chosen phone emulation is used. 
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Setting Connection Settings 
You can customize the Browser ADK to the connection available using the Connection 
Settings window (Figure 5). 

To access the Connection Settings window: 

• Choose the Tools > Connection Settings menu item 

The HTTP connection simulates access to s network. It can be a direct connection to the 
Internet or an HTTP Proxy connection. If you are using a direct connection to the Internet, 
select the Direct Connection to Internet radio button and proceed. If you are using a proxy 
connection, select the Manual proxy configuration radio button, then enter the IP Address 
and Port number of the proxy server. 

 

Figure 5. Use the Connection Settings window to configure the Internet connection. 
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The Connection Settings window options include: 

Option Description 

Direct Connection to Internet Select this option if working without a proxy. 

Manual proxy configuration Select this option if working with a proxy. 

Native HTTP Connection Select to use Native HTTP stack (based on 
Microsoft MFC APIs). 

Phone HTTP Stack Connection Select to use phone implementation stack. 

Address Enter the proxy server address. 

Port Enter the port ID used by the proxy server. 

Bypass proxy server for the 
following domain names 

Enter the domain names that the proxy should not 
use within the intranet. 

URL Enter the home page URL for the phone. 

 

The Browser ADK supports two different stacks including: Windows native stack and 
phone stack. The Windows native stack uses Windows MFC (Microsoft Foundation 
Classes) APIs to fetch content using the HTTP protocol. The phone stack uses the actual 
code that resides in the phone.   

NOTE: One stack type must be chosen for the IDE to operate. 

Local Content Uploading 
The Browser ADK cannot fetch images from local files that are specified using the 
file://link format. All local images are expected to be located in the phone file 
system which is located at <ADK Installation directory>/dl_fs_root/ 
a/. Use the upload images feature to move local image files into the phone file system 
folder, which acts as the root directory for the phone in the NT environment. 

 

Figure 6. Image Uploading window. 
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To upload images: 

1. Choose the Tools > Upload Images… menu item   

The Image Uploading window appears (Figure 6). 

2. Click the “…” button to locate and select the image files to upload 

The Upload Images from… window appears. Use the controls in this window to 
locate and select one or more images to upload, and then click Open. 

3. Enter the name of the destination folder in the Destination Folder Name text box 

If nothing is entered in the Destination Folder Name text box, the default destination 
folder <ADK Installation directory>/dl_fs_root/a/ receives the 
uploaded images. 

4. Click OK 

The selected images are uploaded to the destination folder. 

Using Bookmarks 
The IDE lets you bookmark locations in source files and jump directly to them at any time 
during a development session. 

To toggle bookmarks on or off: 

• Position the editing cursor in the line to bookmark 

• Select the Edit > Bookmarks > Toggle Bookmark menu item 

A blue bookmark appears at the start of the line, or disappears if one already existed. 

To navigate bookmarks: 

• Select the Edit > Bookmarks > Next Bookmark menu item to jump to the next 
bookmark in the file 

OR 

• Select the Edit > Bookmarks > Previous Bookmark menu item to jump to the 
previous bookmark in the file 

To clear all bookmarks in a file: 

• Select the Edit > Bookmarks > Clear All Bookmarks menu item 

All bookmarks are removed from the source file. 
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Content Testing 

One of the main features of the Browser ADK is the ability to develop and test Internet 
content on a PC using the Phone Simulator. 

Testing Requirements 
You must have the following items in order to properly test Internet content in the Phone 
Simulator: 

• Internet content sources 

• Content server containing Internet content 

• Browser ADK to bring them together 

Internet Content 

The Internet content is stored in files that are generated from any of the languages 
supported by the Browser ADK. The content can be created by you or come from content 
readily available on the Internet. The languages supported include: 

• XHTML 

• CHTML 

• CSS 

In addition, you can create content files using the Browser ADK’s editor and test them in 
the Simulator. 

Content Server 

A Content Server is a device that hosts content and sends it to either the Phone 
Simulator of the mobile device when requested. A content server can be: 

• Local server–files are hosted on your PC for easy access 

• Remote server–files are located at any URL reachable by the PC or mobile device 

No matter where the content is located, the Browser ADK seeks it out, opens it into the 
Phone Simulator for viewing, and loads the source into a window for comparison. This 
enables you to verify that the source describes exactly what is shown on the Simulator 
screen. 



18 

 

Browsing Internet Content on the Emulator 
Use the following to test Internet content files in the Simulator whether they are stored on 
a local or remote server. 

To test Internet content: 

1. Launch the Browser ADK 

The Browser ADK and Phone Simulator windows appear. 

2. Configure connection settings (optional) 

If not already configured, or you need to change the settings, choose the Tools > 
Connection Setting menu item. Refer to the section Mouse Shortcuts for more 
information. 

3. Open the Internet content  

To open a local Internet content file: 

a. Choose the File > Open menu item 

b. Click the Browse button to locate and select the file 

c. Click OK 

OR 

To open a remote Internet content file: 

a. Type the website’s URL into the Go field in the Browser ADK window 

b. Press Enter 

The Browser ADK opens the file into a source window. 

4. Choose the Tools > Simulate menu item 

The Phone Simulator displays the Internet content. 
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Troubleshooting 

Most of this section deals primarily with subtle installation problems. 

Problem: The Browser ADK IDE application dies on launch. 

Solution: The application can’t locate and utilize the database objects it needs to 
function. Try running the Data Access Components installer, mdac_typ.exe, which is 
located in the directory ..\Motorola\Browser ADK 2.1\Jre1.3. This will 
install the Data Access Components and the DAO objects. 

 

Problem: When you launch Browser ADK IDE, it reports “The procedural entry point 
HttpSendRequestExa could not be located in the dynamic link library WININET.dll” and 
quits. 

Solution: You’re running the Browser ADK on a vintage version of Windows NT 4.0 that 
has only Internet Explorer (IE) 3 installed. The IDE is looking for specific Internet protocol 
interfaces that are only available with IE4 or later. Download the latest version of the 
browser that is compatible with NT 4.0 and install it. 
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