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An introduction to UIQ/Symbian development 
This article is a supplement to educational material available via the MOTODEV developer site such as: 

• “Building, Packaging, Signing, And Deploying From The Command Line”  

• “QuickStart: MOTODEV Studio, MOTODEV Studio for UIQ”  

Additional related material is provided by external technology partners such as UIQ, Symbian and 
Symbian Signed and are cited in the References section along with some useful links in Appendix A. 

This article aims to provide you with a brief overview on how to develop a UIQ native application for 
Motorola UIQ devices. The focus is on two audiences, commercial developers and non-commercial 
developers. A commercial developer is one who intends to sell their Symbian signed native UIQ 
application. This requires a publisher ID, and normally, testing via the emulator and an actual device.  A 
non-commercial developer may be a student, a hobbyist, or someone interested in developing for the 
UIQ/Symbian platform but not intending to have Symbian sign the application for commercial purposes or 
someone not having access to an actual device. We will only discuss the native application development 
process. 

Background 
Motorola UIQ devices are mobile phones based on the Symbian operating system (OS). The OS uses the 
UIQ Graphical User Interface (GUI) and development platform, and provides additional components to 
the Symbian OS. Both native and Java ME applications can be developed on this platform. Some well 
known Motorola UIQ devices based on the Symbian/UIQ platform are the A1000, M1000, MOTO Z8, and 
MOTO Z10. 

Commercial development steps  
1 Obtaining the tool and IDE 

2 Building an application 

3 Using the emulator 

4 Packaging and signing an application 

5 Installing the application 
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Table 1: Commercial developer track  

Requirements 

Subscriptions/Memberships: 

 Publisher ID: www.trustcenter.de/en/index.htm 

 Symbian Signed Account: www.symbiansigned.com 

 UIQ Developer Account: http://www.developer.uiq.com/ 

Software: 

 Windows 2000/ Windows XP 

 Motorola UIQ handset 

Hardware: 

 1.1 GB required 

 UIQ SDK 3.1 or higher dependent-specific device/SDK requirements: www.symbiansigned.com 

Optional software: 

 MOTODEV Studio for UIQ: https://developer.motorola.com/docstools/motodevstudio/uiq/downloads/ 

 Motorola PcSync: https://developer.motorola.com/docstools/motodevstudio/uiq/downloads/ 

Non-commercial development steps  
1 Obtaining the tool and IDE 

2 Building an application 

3 Using the emulator 

http://www.trustcenter.de/en/index.htm
http://www.symbiansigned.com/
http://www.developer.uiq.com/
http://www.symbiansigned.com/
https://developer.motorola.com/docstools/motodevstudio/uiq/downloads/
https://developer.motorola.com/docstools/motodevstudio/uiq/downloads/
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Table 2: Non-commercial developer track  

Requirements 

Subscriptions/Memberships: 

 UIQ Developer Account: http://www.developer.uiq.com/ 

Software: 

 Windows 2000/ Windows XP 

 UIQ SDK 3.1 or higher dependent-specific device/SDK requirements 

Hardware: 

 1.1 GB required 

Optional software: 

 MOTODEV Studio for UIQ: https://developer.motorola.com/docstools/motodevstudio/uiq/downloads/ 

 

http://www.developer.uiq.com/
https://developer.motorola.com/docstools/motodevstudio/uiq/downloads/
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Developing UIQ applications 
There are five steps to develop applications for UIQ.  

1 Register at UIQ Developer Community 

2 Download UIQ SDK 

3 Install SDK 

4 Download MOTODEV Studio for UIQ 

5 Install and configure MOTODEV Studio for UIQ 

Register at UIQ Developer Community 
Registration at the UIQ Developer Community site is required to download the UIQ SDK. Register at the 
following site: https://developer.uiq.com/register.html

 

Download UIQ SDK 
Once you have registered, download the appropriate SDK at the following location: 
https://developer.uiq.com/devtools_uiqsdk.html

 

 

https://developer.uiq.com/register.html
https://developer.uiq.com/devtools_uiqsdk.html
https://developer.motorola.com/docstools/motodevstudio/uiq/downloads/
https://developer.uiq.com/register.html
https://developer.uiq.com/devtools_uiqsdk.html
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For the most current list of Motorola UIQ/Symbian devices, refer to the 
https://developer.motorola.com/products/handsets/ page and filter on Operating System, selecting either 
UIQ or Symbian. Once you click to select a particular handset, the resulting product page lists the UIQ 
SDK version to download.  

NOTE:  MOTO Z8 supports the UIQ 3.1 SDK while MOTO Z10 supports the UIQ 3.2 SDK 

Install SDK 
The installation installs four components: 

 Emulator 
 C++ developer component 
 Java ME component 
 UIQ SDK documentation  

Refer to the UIQ SDK release notes and/or ReadMe.txt for complete details regarding these components. 

Once you have downloaded the UIQ SDK file, double click on the executable to start the installation and 
follow the prompts accordingly. We recommend that you select an empty or non-existing directory as the 
install location. 

Once the SDK is installed, depending on the UIQ SDK version, you may be required to install the two 
compilers, both of which are included within the SDK installation package.  

 GCC compiler (GCCE) for device builds 
 X86 compiler (WINSCW) for emulator builds  

Please refer to UIQ FAQ Document 25 for more information regarding compiler installation. Release 
notes and known issues can be found in the ReadMe.txt typically located in the default path Symbian > 
UIQversion (where <version> refers to a specific SDK version name for example: UIQ3.1, or 

 

https://developer.motorola.com/products/handsets/
http://developer.uiq.com/forum/kbclick.jspa?categoryID=18&externalID=25&searchID=314207
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UIQ3.3SDK_Beta) of the SDK installation directory. Release notes are also available from the link to the 
right of the UIQ SDK download link.   

Download MOTODEV Studio for UIQ 
To download MOTODEV Studio for UIQ, you need to log into the MOTODEV Developer portal site. 

http://developer.motorola.com/docstools/motodevstudio/uiq/

Install MOTODEV Studio for UIQ 
Double click the MOTODEV Studio for UIQ executable to start the installation process. Follow the 
installation wizard to install MOTODEV Studio for UIQ. Ensure that MOTODEV Studio for UIQ is installed 
on the same drive where you installed the UIQ SDK in the previous step.  

 

 

http://developer.motorola.com/docstools/motodevstudio/uiq/
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Building a native application 
Building a native application applies to both commercial and non-commercial developers. 

 

Register at 
Symbian 
Signed 

Request 
Application ID 

Modify 
HelloWorld 

Build 
HelloWorld via 
Commandline 

Build 
HelloWorld 

via IDE 

There are five steps to building a native UIQ application: 

1 Register at Symbian Signed 

2 Request application UID 

3 Modify HelloWorld 

4 Build HelloWorld via command line 

5 Build HelloWorld via IDE 

Register at Symbian Signed 
This is a required step for commercial developers to request application Universal Identifiers (UIDs). Non-
commercial developers are not required to follow this step. Non-commercial developers can use a test 
UID (i.e. in the range 0xE0000000 to 0xEFFFFFFF) which does not require a Symbian Signed account. 

 

https://developer.uiq.com/register.html
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Open a browser and go to https://www.symbiansigned.com/app/page. Select the “Register now!” link, 
illustrated in the next figure circled in red. 

 
Follow the on-line form to pre-register for your Symbian Signed account by entering a valid email address 
and selecting the Ok button.  

 
A confirmation email for pre-registration will be sent to the email account entered in the above form. At 
the time of this writing, the email contains a link to the Symbian Signed site to complete the registration 
process. Enter the required information into the form and submit your request. 

 

 

https://www.symbiansigned.com/app/page
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Request application UID 
This is the required step for commercial developers. Login to the Symbian Signed site and select the 
[UIDs] link then the [Request] link as shown below.  

 
Since the development is targeting Symbian OS 9.x, select the [Protected Range] link. 
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Fill in the appropriate information for all mandatory fields and select the Submit button to receive your 
UIDs. Developers are still able to use UIDs from the Unprotected range during test phase, but ultimately, 
commercial developers need to use UIDs from the Protected range for a Symbian Signed application and 
need to follow these steps. 

 
You will receive your UID, or UID range, directly from the Symbian Signed website when the page 
refreshes.  
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Modify HelloWorld 
The QHelloWorld application uses a project identifier UID value of 0xE0001001 which is within the test 
range. Commercial developers can follow this step to modify the QHelloWorld sample application UID 
from this test range value to a UID value they received through Symbian Signed. For example as shown 
above, the UID 0x2001A224 can be used in place of 0xE0001001. 

The QHelloWorld application is available in the <UIQ SDK>/Examples/UIQ/QhelloWorld directory after 
SDK installation and can be used as the basis of an application skeleton to create your own unique 
application. In QHelloWorld, the test UID is used in four files. Replace the test UID with one of the 
requested UIDs in these files:  

<UIQ SDK>/Examples/UIQ/QhelloWorld/Group/HelloWorld.mmp 

<UIQ SDK>/Examples/UIQ/QhelloWorld/Inc/HelloWorldUid.h 

<UIQ SDK>/Examples/UIQ/QhelloWorld/Group/SIS/HelloWorld_winscw.pkg 

<UIQ SDK>/Examples/UIQ/QhelloWorld/Group/SIS/HelloWorld_gcce.pkg 

Build HelloWorld via command line  

Open a command prompt and navigate to the Examples\UIQ\QHelloWorld\Group within your UIQ SDK 
installation directory. The following are commands necessary to build the application and a brief 
explanation of each. See the UIQ SDK documentation for more details. 
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The bldmake bldfiles command processes the component description file (bld.inf) and creates an 
ABLD.BAT file within the same directory as the component description file. 

 
The emulator build command  abld build <TARGET> <BUILD TYPE> abld build winscw udeb 
builds a debug version that can be run and tested in the emulator.  

 
The Device build command abld build gcce urel builds a device release version that can be 
installed on the handset. 

 

Using MOTODEV Studio for UIQ to build HelloWorld 
MOTODEV Studio for UIQ is the recommended Integrated Development Environment (IDE) for 
development on the UIQ platform. The IDE also includes project templates that you can modify quickly to 
develop your applications. See the section Steps to develop UIQ applications earlier in this article for 
information on obtaining and installing MOTODEV Studio for UIQ. 
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Start MOTODEV Studio for UIQ: Start > Programs > MOTODEV Studio > MOTODEV Studio for UIQ 
v0.5.0 > MOTODEV Studio for UIQ v0.5.0. 

 
To create a HelloWorld application using the included template, select the following from the MOTODEV 
menu: MOTODEV > Studio for UIQ > Create new project 

1 From the Create new MOTODEV UIQ Project dialog, enter a meaningful name for the project in the 
Project name textbox (HelloWorld is used in this example). 

2 Expand the UIQ 3.x Application directory in the Project types pane and select the Hello World 
Template (UIQ 3.3 Beta) project. 

.  
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3 Select UIQ 3.3 Beta Emulator Toolchain from the Toolchain pane. 

4 Select the [Next>] button to view/modify advanced settings for the project or select [Finish] if you are 
done. 

 
See the Help > Help Contents menu for further explanation of the settings available from the [Advanced 
settings…] button. Many of these properties are still available to the developers after project creation from 
the Project > Properties menu. 

5 With the project selected in the Project Explorer pane, select Project > Build Project menu.  

 
The Console Tab displays build information and should complete with a ‘Build Successful!’ message. See 
Appendix B: Troubleshooting for hints on fixing any issues that arise at this point.  
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6 Developers can substitute their own UIDs, as stated in the building from command line section, by 

modifying the following files in the project and then rebuilding the Project as in step 5 above. 

Inc/HelloWorldUid.h 

Group/HelloWorld.mmp 

Group/SIS/HelloWorld_gcce.pkg 

Group/SIS/HelloWorld_winscw.pkg 

 

 

 



 

 

 

Technical Article Page 19   

Using the emulator 
The emulator can be used by both commercial and non-commercial developers. Here are the steps for 
using the emulator: 

1 Launch emulator 

2 Via command line or via MOTODEV Studio for UIQ 

3 Modify and test HelloWorld via the emulator 

 

Launch 
emulator 

Via command 
line 

 Modify then 
testing via 
emulator Via MOTODEV 

Studio for UIQ 

Launching HelloWorld using the command line

Start a DOS window from Start > Programs > Accessories > Command Prompt 

Executing the ‘epoc’ command launches the emulator. 

 
The emulator can be operated using your PC mouse key presses. You can also activate the scroll bar on 
the right hand side of the display using your PC mouse. Use your mouse to navigate to the Application 
Launcher once the emulator has started up. Select the Hello World program by clicking on the four way 
navigation keys then the FIRE/SELECT key to launch the Hello World application.  
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Launching HelloWorld using the IDE 
Select [Run] > [Run As] > [MOTODEV Application] to open the Run dialog. Select the [Run] button to 
launch the application in the emulator. The emulator launched from the IDE with these steps is the same 
emulator as the one launched from the command line with the epoc command, so developers can 
operate the emulator in the same way to test the HelloWorld application. 
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Modifying and testing the HelloWorld application 
The final part in this build section covers a modification in the application, rebuilding the project, and 
verifying the modification in the emulator launched from the IDE. For this demonstration we will modify the 
name that displays in the Application launcher screen. 

• Open the Reg/HelloWorld_loc_rls file in the Project Explorer window by double-clicking the file 
or by dragging and dropping the file from Project Explorer into the workspace. 

• Modify the String_r_helloworld_caption value from “HelloWorld” to “My Project” or some 
other string of your choice. (The double quotes are necessary). 

• Save the change by selecting the File > Save menu. 

• Rebuild the project from the Project > Build Project menu. 

• Launch the emulator to verify the modification using the Run > Open Run Dialog… menu. 

• Select [Run] to launch emulator and verify that the modification displays in the emulator Application 
Launcher. 

 

 

 



 

 

 

Technical Article Page 22   

 

Signing and packaging an application 
Here are the steps for commercial developers to package and sign an application: 

1 Signing overview 

2 Signing capabilities  

3 Signing options 

4 Packaging and signing HelloWorld 

Signing overview 
Signing is the process of using a tamper-proof digital certificate to encode an application. In order to 
access the “Capability protected” APIs in a Symbian OS application which are declared at build-time, a 
digital certificate is required. A capability is a command statement included in a native application's MMP 
build file and/or a token used to allow access to a protected resource. For complete details on regarding 
“Symbian Signed” visit the portal site (https://www.symbiansigned.com). This article briefly describes four 
signing options available to developers. As an alternative, applications that only require platform security 
capabilities belonging to the group “user” or “basic” capabilities can use the self-signing option described 
in Appendix C.  

Signing capabilities  
The Symbian OS Platform Security Model defines 20 capabilities. The mechanism used to grant 
capabilities to applications is via the signing process. There are four groupings of capability types.  

User Capabilities – User capabilities are available through all signing options. They are: 

 LocalServices 
 Location 
 NetworkServices 
 ReadUserData 
 UserEnvironment 
 WriteUserData 

System Capabilities – All system capabilities, including restricted, are available through Open 
Signed (with a Publisher ID) and Certified Signed options. They are: 

 PowerMgmt 
 ProtServ 
 ReadDeviceData 
 SurroundingsDD 
 SwEvent 
 TrustedUI 

https://www.symbiansigned.com/
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 WriteDeviceData. 

Restricted Capabilities – Express Signed does not allow access to restricted capabilities (CommDD, 
DiskAdmin, NetworkControl, and MultimediaDD). 

Device Manufacturer Capabilities - Symbian Signed refers to the most sensitive capabilities, 
specifically AllFiles, DRM, and TCB, as Device Manufacturer Capabilities. These are only available 
through the Open Signed (with a Publisher ID) and Certified Signed options and require Device 
Manufacturer approval. 

Signing options 
Capabilities are listed in an application’s MMP file depending on the API being accessed. The signing 
options available to developers are mentioned here and described in the next section.  

Open signed 
Open signed provides two signing methods which makes it easy for developers to sign applications for 
limited deployment to known devices, either for testing or for personal use. Deployment is restricted by 
the device’s International Mobile Equipment Identity (IMEI). 

Open signed online 
Open signed online has these features: 

 Simple online process 
 Publisher ID not required 
 Symbian Signed account not required 
 Tool downloads not required, so it is platform independent 
 All User and System Capabilities may be requested (excludes the Restricted Capabilities and 

Device Manufacturer Capabilities) 
 Installation of applications is restricted to one device, specified by the IMEI 
 No cost to developers 
 UIDs from the protected range must have been allocated to the email address associated with 

Symbian Signed account 
 UIDs from the "development range" may be used 

Open signed offline 
Open signed offline has these features: 

 Publisher ID is required 
 Symbian Signed account is required 
 All user, system and restricted capabilities may be requested 
 Applications are restricted by IMEI, but up to 1000 devices may be specified 
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 The request process generates a Developer Certificate which is downloaded and used for local 
signing of applications 

 Developer Certificates can be used to sign multiple Symbian Installation Script (SIS) files. 

Express signed 
One attractive characteristic of this signing option for developers wishing to reduce development costs is 
that no independent testing is required. However, applications are audited for compliance.  

 Publisher ID is required 
 Symbian Signed account is required 
 User and System Capabilities may be requested (Restricted Capabilities cannot be requested) 
 Unrestricted application deployment 
 Signed applications are valid for ten years from the date of signing 
 Single applications and multiple batched applications may be submitted 
 Independent testing is not required, but applications must meet the Symbian Signed Test Criteria, 

and must have been tested on that basis before submission  

Certified signed  
This option is recommended for commercial developers targeting Motorola UIQ devices. It provides 
access to all but Device Manufacturer Capabilities, but requires applications to be submitted for 
independent testing. Certified Signed applications are entitled to use the ‘for Symbian OS’ logo to add 
differentiation and brand building. The main features are: 

 Publisher ID is required 
 Symbian Signed account is required 
 Applications must be submitted to a Symbian Signed accredited test house as part of the signing 

process 
 All User, System, and Restricted capabilities may be requested 
 Access to Device Manufacturer capabilities requires manufacturer approval 
 Signed applications are valid for ten years from the date of signing 
 Single applications and multiple batched applications may be submitted 
 Unrestricted application deployment 
 A “Fast Track” option is available for Certified Signed 

Packaging and signing HelloWorld  

Packaging involves creating an installation file (.SIS) based on the statements included in a package 
(PKG) file. Two methods of packaging the HelloWorld application are demonstrated below. These steps 
assume that a developer certificate and key have already been obtained. For more detailed instructions, 
see the, “A Guide to Symbian Signed” document available on the Symbian Signed site. 
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Packaging via command line 
Open a Command prompt and navigate to the QHelloWorld UIQ example located in your <UIQ SDK > 
\Examples \UIQ directory. These steps assume the application has already been built. The result of 
executing the makesis command is an unsigned .SIS file. 

 

Signing HelloWorld via command line 
Execute the signsis command to sign the application and get a signed SIS file. 

signsis <unsigned_sis_file_name.sis> <signed_sis_file_name.sis> 
<certificate_name.cer> <key_name.key> <password>  

 

Signing HelloWorld via MOTODEV Studio for UIQ 
After building a GCCE Device target version of your application you are ready to package and sign for 
deployment to the target device. Connect your device to a PC using a USB cable or Bluetooth wireless 
connection. Right-click on the project name in Project Explorer pane and select [Export…] as shown 
below.
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Select [Studio for UIQ Package] from Export applet as shown below. 

 
Select the [Browse…] buttons and select your certificate and your key files and enter the password 
associated with them as shown here. 

 
 Select [Finish] to create the signed .SIS file for deployment to the target device. 
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Installing your application 
Commercial developers wanting to deploy their application need to complete the following steps: 

• Deploy via MOTODEV Studio for UIQ 

• Obtain Motorola PcSync 

• Install PcSync 

• Install HelloWorld 

Deploy via MOTODEV Studio for UIQ 
Connect your PC to the target device using USB cable. When using a Bluetooth wireless connection 
method, ensure you are properly connected with the target device using the PcSync ‘How to connect 
wizard’. Alternatively, PcSync can be used directly for deployment. See Appendix D for PcSync 
installation and application deployment. 

Right-click on project in the Project Explorer pane and select Run As… > Open Run Dialog menu. 

 
 

 

http://compass.mot.com/doc/271094145/direct.motorola.com/motography/pccd_vista_32.zip
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Select [Run] to deploy the application to target device.  
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Appendix A: Useful links 

Registration Link 
https://developer.uiq.com/register.html

Download Links 

UIQ SDK Download link: 
https://developer.uiq.com/devtools_uiqsdk.html

Motorola PcSync download link: 
direct.motorola.com/motography/pccd_vista_32.zip 

Developer Resources 
UIQ Developer Community, Forums & FAQs 

http://developer.uiq.com/ask.html

 

FAQ 25 Setting up the SDK tools and compilers.   

http://developer.uiq.com/forum/kbclick.jspa?categoryID=18&externalID=25&searchID=314207 

 

Symbian Signed 

http://symbiansigned.com/

 

Symbian Developer Network 

http://developer.symbian.com/main/index.jsp

https://developer.uiq.com/register.html
https://developer.uiq.com/devtools_uiqsdk.html
http://developer.uiq.com/ask.html
http://developer.uiq.com/forum/kbclick.jspa?categoryID=18&externalID=25&searchID=314207
http://symbiansigned.com/
http://developer.symbian.com/main/index.jsp
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Appendix B: Troubleshooting 

Compilation and build issue when building Symbian OS application  
If you experience problems building for WINSCW target using the template in MOTODEV Studio for UIQ, 
please refer to the following UIQ SDK FAQ to verify your compiler path configuration. 

[25] Setting up the SDK tools and compilers.  

https://developer.uiq.com/forum/kbclick.jspa?categoryID=18&externalID=25&searchID=321450 

Unexpected Windows OS behavior after UIQ SDK installation/uninstall 
In very rare cases installing the SDK causes a loss of the environment paths. To help you restore your 
paths check <installdir>/path.log or save your path environment to desktop before installation. Restore 
your environment path to original if you experience any unexpected behavior due to missing environment 
path. 

GCCE target build fails with [*** missing separator.  Stop] build errors 
Verify that the C:Program Files\CSL Arm Toolchain\bin; path is included in your environment path 
statement and that it is not enclosed in quotes.  

Incorrect: <path statement>;“C:\Program Files\CSL Arm Toolchain\bin;” 

Correct: <path statement>;C:\Program Files\CSL Arm Toolchain\bin; 

Signing issues 
1 “Security Information: Component failed security check. Cannot install.” 

This information message appears when trying to install an unsigned native Symbian application to 
the Motorola UIQ device. Signing the application and reinstalling should resolve this issue. At this 
time, Motorola UIQ Platform Security policy requires that all native Symbian applications be signed in 
order to install to the device regardless of whether or not the application uses a specific capability or 
not. This message also appears when the date and time of the device is set to a date/time outside of 
the certificate’s valid time frame. Ensure the date and time of the device is set properly. 

2 “Cannot install” Constraints imposed by a developer mode certificate have been exceeded. 

The certificate used to sign this application is not associated to the device IMEI to which the 
application is being installed. Installing the application to the correct device or resigning with the 
correctly associated certificates resolves this issue. 

3 “Cannot install” An upgrade failed because the package being installed is not a valid upgrade. 

This message appears when trying to update a signed application (already installed on the phone) 
using a self-signed application. The way to resolve this issue is to uninstall the signed application and 

https://developer.uiq.com/forum/kbclick.jspa?categoryID=18&externalID=25&searchID=321450
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than install the self-signed application, or, sign the self-signed application and perform the update on 
the phone.   

4 Symbian Signed issues: 

 
This error indicates that the UID used in the application does not match a UID associated with the 
email address used when signing an application via Symbian Signed online option. Ensure the email 
address used when requesting Symbian Signed Online signing matches the email addressed used 
when requesting UIDs from the Protected range.  

General signing guidelines 
Size limitation on files submitted for signing. 

 Open Signed Offline: No effective limit, done locally on your development machine 
 Open Signed Online: 4Mb 
 Express Signed: 4Mb 
 Certified Signed: 40Mb 
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Appendix C: Self-Signing 
Applications can be signed using the createSIS command which can take a package .PKG file as input 
and generate a self-signed .SIS file as output which can be installed on a Motorola UIQ device. Currently 
released Motorola UIQ devices allow installation of self-signed applications. 

>createsis create <package_file.pkg > 

 
 

When using the createsis tool, you will be prompted to enter a four letter ‘passphrase’ to complete the 
process. See the UIQ SDK documentation for complete details. 
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Appendix D: PcSync installation and application 
deployment 
PcSync is available free from the MOTODEV Studio for UIQ download website under Basic 
Requirements: https://developer.motorola.com/docstools/motodevstudio/uiq/downloads/.  

Download the zip file to your PC and unzip the package. Start the download by double-clicking the 
CD.exe file at the root of the PCSync directory. Select [Install now] button from the Installation Wizard. 

 
 

Follow the Installation Wizard steps

 
 

 

https://developer.motorola.com/docstools/motodevstudio/uiq/downloads/
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Read the License Agreement then select top radio button (I accept…) to continue installation. 

 
Select [Next] 
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Select [Install]. Allow several minutes for the installation to complete. 

 
Read and select [I Agree] to continue to install Multimedia Services (Windows Media Player Plugin) 
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Select [Install] 

 
Select [Next] 

 
 

 

 

 

 



 

 

 

Technical Article Page 39   

Select [Finish] to complete 

 
Close Installation Wizard by selecting [Done].  

NOTE:  Installation completion requires a system restart. 
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PcSync starts automatically the next time the PC starts. With a USB cabl
select the “How to connect” button from PcSync startup screen. 

e, connect to the MOTO Z8 and 

 
Select [Next]. 

 
Selec [Next] 
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Follow the on-screen directions and select [Next] 

 
Install the Hello World application to on the MOTO Z8 handset using a USB connection and the PcSync 
software. Launch PcSync software on your PC from the [Start] > [Programs] > [Motorola] > [PcSync] 
menu. PcSync software will detect your handset after it is successfully connected via USB and enable the 
Application Installer button on the main screen.  
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The first time the Application Installer is run you will be prompted with the Application Installer file types 
window prompt. You may wish to select the [Do not show this dialog again] checkbox to accept the 
default settings when installing applications.  

 
PcSync software allows you to drag and drop the SIS file previously generated onto the currently 
connected handset pane.  
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The rest of the installation process occurs on the target handset itself. Select [Install] > [Continue] (This 
installs on Phone default location) – [Yes] to run the application. The result is the Hello World application 
executing on the MOTO Z8 handset. 

 
 

Finally you may close the PCSync software once the application is successfully installed.  
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